Вкладка “Виконання процедури” для задачі
Виклик Процедур 1С:Підприємства 8

“Процедура:”

  • “Виконання обміну”
    Виклик процедури виконання обміну даних
    “ВыполнитьОбменДаннымиДляНастройкиАвтоматическогоОбменаДанными(КодНастройки)”
    загального модуля “МодульРегламентныхЗаданий”.

    В якості параметру передається код елемента довідника “Настройки выполнения обмена”. Працює з типовими конфігураціями (не керований додаток).

  • “Виконання обміну для конфігурації керованого додатку”
    Виклик процедури виконання обміну даних
    “ВыполнитьОбменДаннымиПоРегламентномуЗаданию(КодСценарияОбмена)”
    загального модуля “ОбменДаннымиСервер”.

    Як параметр КодСценарияОбмена – Строка – код елемента довідника “Сценарии обменов данными”, для якого буде виконаний обмін даними. Працює з типовими конфігураціями реалізованими як керований додаток.

  • “Обмін з WEB-сайтом”
    Виклик процедури виконання обміну даних
    “ЗаданиеОбменССайтом(КодНастройки)” загального модуля “ПроцедурыОбменаССайтом”.

    В якості параметра передається код елемента довідника “Настройки обмена с WEB-сайтом”.

  • “Обмін з WEB-сайтом для конфігурації керованого додатку”
    Виклик процедури виконання обміну даних
    “ЗаданиеВыполнитьОбмен(КодНастройки)” загального модуля “ОбменаССайтомСобытия”.

    В якості параметру передається код налаштування обміну з “Узлы обмена с сайтом”.

  • “Виконати фрагмент коду”
    Виклик експортної процедури “ВыполнитьКод(ФрагментКода)” загального модуля EffectorSaver. Потрібно доопрацювання конфігурації. Детальніше в довідці.

    В якості параметру передається фрагмент коду (ім’я процедури) на вбудованій мові який необхідно виконати.

  • “Обчислити фрагмент коду”
    Виклик експортної функції “ВычислитьКод(ФрагментКода)” загального модуля EffectorSaver.
    Вимагається доопрацювання конфігурації. Детальніше в довідці.

    В якості параметру передається фрагмент коду (ім’я функції) на вбудованій мові, який необхідно виконати. Повернене значення буде записано до журналу. Значення повернення 0 (нуль) розглядається як помилка виконання задачі.

“Код налаштування:/Виконати код:”
Для виконання процедур обміну, в якості коду налаштування необхідно вказати код елемента довідника відповідної установки.
Для “Виконати фрагмент коду”/”Обчислити фрагмент коду” в параметрі вказується повністю рядок запуску процедури/функції з параметрами.

Доопрацювання конфігурації

1. У конфігурації додайте загальний модуль

Имя: EffectorSaver
Клиент = Истина
Сервер = Истина
Внешнее соединение = Истина

dorabotka-konfiguracii-1С-dobavit-obshhij-modul

2. У тіло модуля вставте наступний текст

Процедура ВыполнитьКод (ФрагментКода) Экспорт

Выполнить (ФрагментКода);

КонецПроцедуры

 

Функция ВычислитьКод (ФрагментКода) Экспорт

Рез = “”;

Выполнить(“Рез=”+ ФрагментКода);

Возврат Рез;

КонецФункции

 

Функция Тест() Экспорт

Возврат (“Тест вызова функции”);

КонецФункции

dorabotka-konfiguracii-obshhij-modul

Перевірка

Створіть нову задачу “Виклик процедур 1С:Підприємства 8”.

Налаштуйте підключення до бази.

У полі “Процедура:” встановіть “Обчислити фрагмент коду”.

У полі “Виконати код:” вставити EffectorSaver.Тест()

Збережіть завдання. Виберіть Меню “Задача” — “Виконати зараз”.

У журналі повинен з’явитися запис з вмістом: “Значення повернення: Тест виклику функції”.

Статьи и документация